Windows 10 & iCloud

  • 1
  • Problem
  • Updated 3 months ago
Since installing CE I cannot connect my Windows 10 laptop to iCloud. On sign-in I get a dialogue that says "There was an error connecting to the Apple ID server."



Any ideas?
Cheers
Phil
Photo of Phil Moore

Phil Moore

  • 2 Posts
  • 0 Reply Likes

Posted 2 years ago

  • 1
Photo of Samantha

Samantha, Employee

  • 148 Posts
  • 13 Reply Likes
Hi Phil,
    Thanks for the post! Do you happen to know what version of Covenant Eyes you've installed? You can check it by right clicking on the eyeball icon in the lower right hand corner and choosing "About". This will give us some insight into what the issue could be.

Samantha
Photo of Phil Moore

Phil Moore

  • 2 Posts
  • 0 Reply Likes
Hi Samantha,

V6.0.16 is what it reports (although it would appear that I have had this problem ever since installing CE over 6 months ago.

Cheers
Phil
Photo of Annelise

Annelise, Official Rep

  • 247 Posts
  • 13 Reply Likes
Hello Phil,

Sounds like you're running a slightly older version of Covenant Eyes. If you can, could you try upgrading to our latest version, 7.2.22, via our website to see if that fixes the issue with iCloud?

To download our latest version you would need to go to www.covenanteyes.com/myaccount, sign in with your username and password, and the go to the downloads section. You should be able to install our latest version over top of the one you're running now. 

If you need any further assistance feel free to contact our Customer Service at 877.479.1119 or by emailing support@covenanteyes.com

Best regards,
Annelise
Photo of travaglione

travaglione

  • 6 Posts
  • 0 Reply Likes
i have a problem with icloud also.   the sign in box floats off the screen
Photo of Robert B

Robert B, Official Rep

  • 277 Posts
  • 20 Reply Likes
travaglione,

Thanks for posting. Covenant Eyes should have no effect on the position of the iCloud sign in box. As Annelise mentioned above, make sure you are using the newest version of CE (currently 7.2.41) and, if you're still experiencing that unusual behavior, then give our Customer Service Team a call at 877-479-1119.

Robert
Photo of Rick Abshier

Rick Abshier

  • 7 Posts
  • 0 Reply Likes
I have this issue as well.  If I uninstall CE (newest version), I can log into iCloud without issue.
Photo of Robert B

Robert B, Official Rep

  • 277 Posts
  • 20 Reply Likes
Rick,

Thanks for posting. I noticed that you also posted about an issue with CE 7.2.79 and Mail for Windows. I saw that Mark from CE encouraged you to use a slightly older version.

I'm curious to know if that fixes both items. And I'm curious about your machine, does it have an anti-virus/security program? Post here when you have a chance, or call us at 989-720-8000.

Thank you,

Robert
Photo of Rick Abshier

Rick Abshier

  • 7 Posts
  • 0 Reply Likes
I reverted back to 7.2.48 and I can get into iCloud with Edge.  
Photo of Robert B

Robert B, Official Rep

  • 277 Posts
  • 20 Reply Likes
Good to know, and thanks for the update!

Did that also fix the Mail for Windows issue?

Thanks again for the update.
Photo of Rick Abshier

Rick Abshier

  • 7 Posts
  • 0 Reply Likes
Yes, Windows 10 Mail works with 7.2.48.