Unable to play EA games...

  • 4
  • Problem
  • Updated 4 years ago
Hey guys,

I noticed after installing Covenant Eyes on my Windows PC I am now not able to play any of my EA games. These games use the Origin client and connect to EA servers. The Origin client connects just fine but the games themselves give errors that they are unable to connect to EA Servers.

I did remove the CE client and the games worked just fine. I also tried the latest BETA CE client, but still no dice.

I am paying for just accountability, why are these things being filtered?

Please fix...

Thanks,
Manny
Photo of Manny Falcon

Manny Falcon

  • 6 Posts
  • 1 Reply Like
  • sad

Posted 4 years ago

  • 4
Photo of Samantha

Samantha, Alum

  • 148 Posts
  • 13 Reply Likes
Hi Manny,
    Thanks for the post! We are aware with the conflict between Covenant Eyes and the Origin client.  Our developers are currently working on a version to fix the conflict, but in the meantime, one of our older versions will allow you to use Covenant Eyes as well as run Origin.  This version isn't available through our website, but if you call us we can help you install it on your computer. Our number is 877-479-1119 and we are here from 8AM-12AM EST M-F and 10AM-6PM on Saturday.

Hope that helps!
Samantha
Photo of Manny Falcon

Manny Falcon

  • 6 Posts
  • 1 Reply Like
Thanks for the reply. I will call when i get a chance...

Thanks again,
Manny
Photo of Shawn P

Shawn P, Official Rep

  • 53 Posts
  • 17 Reply Likes
Hi Manny,

I have a developer working on this compatibility issue between Covenant Eyes and EA Origin.  He is just getting started, but he said he may have some questions about your EA Origin configuration.  Would you be willing to answer a few questions if he has any during his investigation?  

We look forward to fixing this issue for you.

Thanks,


Shawn Pillsbury
Covenant Eyes, Inc.
Product Development Manager
shawn.pillsbury@covenanteyes.com
989-720-8189



Photo of Manny Falcon

Manny Falcon

  • 6 Posts
  • 1 Reply Like
Absolutely Shawn.

I will email you my email address and then you can forward it to the developer.

Thanks,
Manny
Photo of fredarters

fredarters

  • 5 Posts
  • 1 Reply Like
This was a few months ago..  I am able to use EA Origin for Siege but now Battlefield 1 is out and wont connect.   I uninstalled CE and it works, reinstalled latest and blocked.  I am only on accountability, not filtering.   The fix for these still in the works? 
Photo of Manny Falcon

Manny Falcon

  • 6 Posts
  • 1 Reply Like
Email Shawn from this thread and he will hook you up! Cheers!
Photo of fredarters

fredarters

  • 5 Posts
  • 1 Reply Like
I'm on version 7.2.0 and it definitely does not work.  Other games like Siege on uPlay works.. just not BF1.   Whats the downside to downgrading to version 5.2?
Photo of Manny Falcon

Manny Falcon

  • 6 Posts
  • 1 Reply Like
No idea, but I know the client works as it's supposed to and I can play BF1...
Photo of Shawn P

Shawn P, Official Rep

  • 53 Posts
  • 17 Reply Likes
Hi guys,

To answer Fredarters question about downgrading to v5.2.106. Our Customer Support team does, in situations like this, have members install v5.2.106 rather than the latest version of Covenant Eyes. All of the core Covenant Eyes functionality is available in v5.2.106, so you shouldn't have any issues. Contact customer support at 877-479-1119 for the link.

Software compatibility is one of the issues we are regularly working to resolve. We'll keep you posted on this forum as we fix this issue with BF.

Feel free to contact me if you have questions or comments at shawn.pillsbury@covenanteyes.com
or 989-720-8189.
Photo of fredarters

fredarters

  • 5 Posts
  • 1 Reply Like
got it.  will try the link tonight.  thanks shawn. 
Photo of Ian Smith

Ian Smith

  • 1 Post
  • 0 Reply Likes
Trying to play the Battlefield 1 Early Access right now and unable to connect. I was able to play the Beta, and have tried every one of EA's troubleshooting methods. It seems like the weak link is Covenant Eyes--any idea how quickly this might be resolved?
Photo of fredarters

fredarters

  • 5 Posts
  • 1 Reply Like
Ian, switching to the 5.2.106 version of CE worked for me in this case.  I had to call to get a link to the download. 
Photo of Lyderic Rijsel

Lyderic Rijsel

  • 3 Posts
  • 0 Reply Likes
I'm having a similar compatibility issue with FIFA 17. I'm unable to use the online portions of the game at all with CE v7.2.4.
Photo of Annelise

Annelise, Official Rep

  • 258 Posts
  • 13 Reply Likes
Hello Lyderic,

Thank you for contacting us and I apologize for problems you've been experiencing with Covenant Eyes and FIFA 17.

We do have a beta available on our website that should resolve your compatibility issues. If you go to My Account on our website, sign in with your username and password, and locate downloads our beta version 7.2.10 is available for installation. You can install 7.2.10 over top of your current version, no uninstall is required.

If this does not solve your compatibility issues please contact our Customer Service at your earliest convenience, 877.479.1119.

Best regards,
Annelise
Photo of Lyderic Rijsel

Lyderic Rijsel

  • 3 Posts
  • 0 Reply Likes
Just a quick note that the v7.2.10 beta did not solve the issue with FIFA 17. I haven't yet contacted customer service, but will do so soon.
Photo of Shawn P

Shawn P, Official Rep

  • 53 Posts
  • 17 Reply Likes
Hi Lyderic,

Our developers are working on a fix that is scheduled to be released tomorrow (10/19/16). Look for v7.2.11 (beta) on our download site after 10am EDT. Please note that they made the change based on the trial version with the expectation that the fix will work on the full release. We'll keep you posted on any new developments.

Thanks,

Shawn
Photo of Lyderic Rijsel

Lyderic Rijsel

  • 3 Posts
  • 0 Reply Likes
Hi Shawn, v7.2.11 does fix this issue. Thank you.