Support for Yosemite

  • 1
  • Question
  • Updated 6 years ago
  • Answered
Any idea when you will have even Beta support for Yosemite?
Photo of Jason Burton

Jason Burton

  • 3 Posts
  • 0 Reply Likes

Posted 6 years ago

  • 1
Photo of John

John, Official Rep

  • 439 Posts
  • 79 Reply Likes
Official Response
Funny you should ask... (From Today's Release notes)

Covenant Eyes versions 2.6.0b23 and later are compatible with Mac OS X 10.10 (Yosemite).
We recommend uninstalling Covenant Eyes prior to upgrading your Mac OS software to OS X Yosemite. Once the system upgrade is complete you may install Covenant Eyes Version 2.6.0b23 to your Mac. 

OS X Yosemite is currently a pre-release software available to developers and beta testers. It will not be available for purchase until this fall. 


So to answer your question, YES! As of Today our Mac team released a build that should be fully compatible with Yosemite. Feel free to go ahead and download the beta and let us know how it works for you! 

Covenanteyes.com/myaccount/downloads

Big Shout Out to the Mac team for delivering this extremely quickly after getting the required keys from Apple
(Edited)