Steam and other apps on my PC no longer work with recent update

  • 1
  • Problem
  • Updated 5 months ago
When I go to open up Steam, and other apps like Fortnite, Spotify, and Forza Hub, they do not open. Before I updated to the latest version of Covenant Eyes, these all worked fine. It is very annoying how my PC is now basically unusable with anything relating to video games. Also, whenever I click on certain sites, they say "can't connect securely to this page." Is this the new way of blocking? I'm not paying $15 a month for my PC to be imprisoned by this.
Photo of Josh Towe

Josh Towe

  • 2 Posts
  • 0 Reply Likes
  • frustrated

Posted 5 months ago

  • 1
Photo of Mark Donovan

Mark Donovan, Quality Assurance Analyst

  • 70 Posts
  • 6 Reply Likes
Hello Josh! As a first instinct, sometimes updates for older versions of Covenant Eyes can encounter issues updating to newer versions. I suspect all that may have happened here is an upgrade issue, and an uninstall and reinstall of our software may well resolve the issue-I would suggest exploring that route first and foremost.

Outside of strict filtering levels/items in your block list, it's abnormal for our software to block the playing of video games, and is almost assuredly a bug. This is not our normal way of blocking. Most users would be told by their filter guardian if they had attempted to prevent them from playing games by adding sites to their block list, so I don't expect that to be the situation here.

If the uninstall/reinstall does not resolve your issue, do you happen to know what version of Covenant Eyes you were on and what version you upgraded to? Additionally, do you know if you are using Internet Accountability or Screen Accountability? Lastly, what operating system are you running here? Windows 10?
(Edited)
Photo of Josh Towe

Josh Towe

  • 2 Posts
  • 0 Reply Likes
Thanks for the quick response! I was on version 7.2.41 and recently updated to 8.0.79. I’m using Internet Accountability and running Windows 10.
Photo of Mark Donovan

Mark Donovan, Quality Assurance Analyst

  • 70 Posts
  • 6 Reply Likes
Okay, wonderful! Were you able to attempt an uninstall/reinstall and if so, how did that work for you? Is the issue still occurring?

If it didn't work for you then let me know, and we can discuss further measures!