Spotify players, slow playback

  • 1
  • Problem
  • Updated 4 weeks ago
Hi there!

Since installing covenant eyes for windows several weeks ago, I have had quite a bit of trouble with spotify. The player seems to react incredibly slowly to my inputs, taking several seconds to complete an action, i.e. play/pause, next song, volume up/down; it feels like I'm using a machine from the early 2000s. All of these issues are related specifically to spotify, and they only occur when spotify is open. No other applications demonstrate this behavior, and I have never experienced issues similar to these prior to installing covenant eyes.

I tried reinstalling spoitify, but that had no affect; I also did a fresh install of covenant eyes. With covenant eyes uninstalled, the issue was no longer present, and playback behaved as usual. However, upon reinstalling CE, the issue came back, leading me to believe that CE is causing some interference specifically with spotify. I should also note that this behavior is also present on the spotify web player used inside a browser when CE is installed.

Yet, what is most frustrating is that none of my activity from within the spotify Windows client shows up in any detailed browsing log report, meaning I cannot troubleshoot addresses that CE may be wrongfully getting hung up on.

I'm at a loss, and my AC partner and I are stumped as to what CE is doing to cause this. This problem is NOT present when CE is uninstalled, but reoccurs upon re-installation.

Any help or pointers are appreciated. Again, I have just reinstalled both CE and spotify on my machine, meaning everything is in fact clean and up-to-date. Thanks for reading, and I hope you have a wonderful day!

Best,
Kevin
Photo of Kevin Knox

Kevin Knox

  • 1 Post
  • 0 Reply Likes

Posted 4 weeks ago

  • 1
Photo of Andy Robinson

Andy Robinson, Official Rep

  • 11 Posts
  • 2 Reply Likes
Hello Kevin,

Thank you for reaching out to us! I'm sorry that you're having trouble with Spotify on your devices.

Looking over the account, it looks like the correct urls for Spotify are in the Allow List. I wonder if there are some other background urls that are getting caught up? 

What I'd like to do is test Spotify with our filter turned off. The administrator on the account can remove that for you. Once the filter has been removed, you will need to refresh Covenant Eyes on your devices for the changes to take effect. Then try to connect to Spotify.

If that improves things with Spotify, it is likely that there are some other background urls that need to be added to the Allow List. If it does not improve things with Spotify, there might be something else going on. Either way, I would suggest calling Customer Support at 877.479.1119 and we can help troubleshoot this.

Thank you,

Andy