Sluggish performance on brand new LG V20. Help?

  • 2
  • Problem
  • Updated 3 years ago
New LGV20 device here with CE installed. Runs fine for a while but I begin seeing significant keyboard lag, and then lag in other programs. It eventually becomes unusable Andis resolved with a reboot. Have tried using task killer and cache cleaners but with no success at restoring functionality to the device-- only a reboot seems to do the trick. I've done a hard reset and restored to factory defaults and tested the phone with and without CE and it appears that CE is the culprit. Any suggestioms on what I can do? It seems like others are experiencing the same thing but I'd love to hear from the developers to see if they are aiming to address this. I'd hate to jump ship but at this point it's crippling my phone.

Thank you!
Photo of tjcazoo

tjcazoo

  • 6 Posts
  • 0 Reply Likes
  • frustrated

Posted 3 years ago

  • 2
Photo of Annelise

Annelise, Official Rep

  • 258 Posts
  • 13 Reply Likes
Hello tjcazoo,

Thanks for your post and I apologize for the difficulties you've been experiencing. In order to better understand the issue you're experiencing I have a few questions:

Do you use the filtering service with Covenant Eyes?
Do you use any screen dimming, app locking, or anti-virus applications on your Android device?
What version of Covenant Eyes do you have installed?

It is possible that a lag on your device could be due to an anti-virus application or other security applications conflicting with Covenant Eyes. We don't conflict with all anti-virus or security applications, but we have run into a few that we were unable to play nice with. 

If you have any of those types of applications you could try temporarily removing them and seeing if your phone's performance improves at all. If this doesn't work or the issue doesn't resolve I would suggest contacting our Customer Service at 877.479.1119 and we would be more than happy to assist you!

Best regards,
Annelise
Photo of Randy Walker

Randy Walker

  • 1 Post
  • 0 Reply Likes
I too am having severe performance issues (my wife has noticed it too).  And since CE is the only thing that was changed it has to be CE.  Videos rarely load now, pages that once loaded fine now take significantly longer  and there is a huge typing lag when using bing or google or even typing a URL.  I am on a Surface Pro 3, and my wife a Surface Pro 4 using Windows Defender.   Even setting CE to accountability only and rebooting, performance is noticeably slow. 
(Edited)