Slow Upload Speeds with CE

  • 1
  • Problem
  • Updated 6 months ago
So I have had CE for a while now, but beginning of the year I built a new PC.  I've had a lot of internet issues since then, some of which I'm now confident are CE related (I had some issues with my ISP earlier in the year which have been resolved.) I've been able to isolate to CE causing issues specifically with my upload speeds.

My internet connection is 30 Mbps down and 2 Mbps up. The download speed is fine I'll generally get the 30 Mbps, however the upload speed is always much slower. 

This is the way my internet behaves as well, I can punch in a web address and the website takes a while before I get a response, however once the response comes in, the page loads quickly. Similarly I have no issues with download speeds from websites. (I don't do enough uploading to really compare)

Now if I boot into my Linux partition on the same computer, or simply uninstall CE from my Windows 10 partition my upload speeds are significantly improved in a speedtest, approaching the 2 Mbps I expect.  The response time in browsing is even significantly improved. 

My guess is something with CE is severely limiting/slowing down any outbound requests from my computer. I've done some researching into similar problems on the forums but haven't had any luck. Here's some more info. 

- I don't use any anti-virus software
- I tried disabling filtering for my user and it was still slow. 
- Speed test on a mobile phone on the same Wifi has no issues.

I know there could be potentially a large number of things that conflict with it, but happy to try whatever steps you guys might suggest. Additionally, I'm located in AUS so if I need to contact your support team, it'll have to be via email.

Hope you guys can help soon, my internet has been bothering me for a while now!
Photo of Jololol

Jololol

  • 4 Posts
  • 0 Reply Likes
  • frustrated

Posted 6 months ago

  • 1
Photo of Robert B

Robert B, Official Rep

  • 231 Posts
  • 16 Reply Likes
Jololol,

Thanks for reaching out.

CE does not work with Linux.

Robert