Problems connecting to Starbucks WiFi

  • 2
  • Problem
  • Updated 5 years ago
I go to Starbucks a lot, and often I have a very difficult time connecting to the WiFi.  It seems that the Starbucks login page for their WiFi will only come up when CE is disabled.  So I try logging out, and then bringing up the page digital.starbucks.com while the CE is still closed.  But inevitable the eye opens up before the page loads, and so I get an error page (https://digital.starbucks.com/error/not-in-store).  I've tried restarting Safari, but no luck.  Even tried killing CE from the Activity Monitor, but didn't work.  I really hate having to restart my whole computer just to log in.  Is there any other solution for this?  This is very frustrating given how often I use public WiFi.  
Photo of Brendan Murphy

Brendan Murphy

  • 3 Posts
  • 0 Reply Likes

Posted 5 years ago

  • 2
Photo of Mark Donovan

Mark Donovan, Quality Assurance Analyst

  • 71 Posts
  • 7 Reply Likes
Sorry about the late response, this is actually my first post.

Our software has made a lot of progress in recent versions on dealing with 20-hour error issues which are similar in nature to this one, so my first question to you would be what version of our software you are running? If you aren't on the current version (5.2.106 on Windows, 2.7.1 on Mac), I would recommend updating your Covenant Eyes software.

Secondly, I just want to confirm-it's only the Starbucks page that's having a problem, correct? You aren't getting any Covenant Eyes error messages about being unable to connect are you?
Photo of Brendan Murphy

Brendan Murphy

  • 3 Posts
  • 0 Reply Likes
Mark, I appreciate the reply.  Yes, I am using the latest version of the software for Mac, and no, I'm not getting a CE connectivity error.  It's just the Starbucks error page.  I have found a way that seems to be working.  If I clear the cache on Safari, sign out of CE, and then go to the Starbucks sign in page that seems to work the best.  It doesn't always work the first time, and I had a time recently it took me a few minutes to get it working.  Still not as seamless as I'd like, but I agree definitely better than it was in the past.  It's got to be something with the way the Starbucks WiFi is setup, because I also go to Chic-fil-A, and have never had a problem. 
(Edited)
Photo of Mark Donovan

Mark Donovan, Quality Assurance Analyst

  • 71 Posts
  • 7 Reply Likes
Have you set up automatic sign in under preferences? Enabling that preference causes Covenant Eyes to attempt to launch when it detects internet activity. I suspect that that may be having a large factor in what is occurring here, but I could be wrong.

If it is enabled, my recommendation would be to disable that preference before attempting to access internet at Starbucks. That should keep our process from automatically starting up when you open your browser.
Photo of JetBlitz

JetBlitz

  • 1 Post
  • 0 Reply Likes
Hi, I've also had the same problem with connecting to Google Starbucks and Chick-Fil-A AT&T wifi.

It took me 3 months to figure out that CE was preventing the Google Starbucks splash page from coming up. So what I usually do is Sign Out from CE, turn off my Wi-Fi, go to 
"Open Network Preferences..."

> Advanced... > and I delete Google Starbucks from the list of recently used Wi-Fi connections.

Then I wait maybe 10 seconds and then turn on my Wi-Fi and select Google Starbucks.

The splash page then comes up in which I accept the Terms of Use, then bam! 
I'm finally connected. 

Covenant Eyes then automatically re-connects.


PS: I will try disabling the automatic sign-in under preferences when I go to another Starbucks.

PSS: This happens also when I go to Chick-Fil-A. 


I have CE version 2.7.1
MacBook Pro (Retina, Mid 2012)
Running OS X Yosemite version 10.10.1
Photo of Brendan Murphy

Brendan Murphy

  • 3 Posts
  • 0 Reply Likes
The process I'm using now when I have this issue that has worked perfectly is as follows:
  1. Disable automatic sign in.
  2. Sign out of covenant eyes.
  3. Clear the cache in my browser.
  4. Open a new page and go to www.google.com
  5. Sign into Covenant eyes when prompted
The Starbucks splash sign in page usually comes up every time.  If for some reason it doesn't.  Then I may try turning off my wifi, then turning it back on and try again.  
Photo of Mark Donovan

Mark Donovan, Quality Assurance Analyst

  • 71 Posts
  • 7 Reply Likes
Good to know. I was a little unclear as to the steps we usually take to get users to login, but give this a whirl if your solution doesn't work for you:

1. Disable auto-sign in
2. Log out of your profile
3. Log back in to your profile
4. Immediately open Safari (or Chrome, or whatever browser you use) and navigate to cnn.com or the like.

That usually brings up the login page around the office. I hadn't thought about clearing the cache, though, that's a good suggestion. Thanks for posting!