New update clashing with programs. Anyway to roll back to an older version?

  • 2
  • Problem
  • Updated 4 years ago
The latest version of CE that rolled out on May 11 is causing several of programs to no longer work that did just before. So is there any way to get back to an old version of CE that obviously won't have this problem?
Photo of Tim Stern

Tim Stern

  • 1 Post
  • 0 Reply Likes

Posted 4 years ago

  • 2
Photo of Annelise

Annelise, Official Rep

  • 258 Posts
  • 13 Reply Likes
Hello Tim,

I apologize for the difficulties you've been experiencing. I know it can be frustrating, but thank you for reaching out to us. We do have some older versions we could take you back to, but we would love to troubleshoot with you to see if we could get the most recent version of Covenant Eyes working with your various programs.

If you could give us a call, at your earliest convenience, we would be more than happy to assist you, 877.479.1119.

Best regards,
Annelise 
Photo of Dan Lucci

Dan Lucci

  • 2 Posts
  • 0 Reply Likes
I am having a similar problem. Yesterday I installed CE on two computers and on both, my backup software, Crash Plan, stopped working. When I removed CE from both systems, Crash Plan started working again. A third computer I have, that has both software products installed for many months, seems to continue to be working without problems. I would like some help to get this problem resolved.
(Edited)
Photo of Dan Lucci

Dan Lucci

  • 2 Posts
  • 0 Reply Likes
I called support this morning and was able to install a prior version of CE which looks like it is working well with my other software. Problem resolved from my perspective.