Mac Beta testers wanted!

  • 1
  • Idea
  • Updated 4 years ago

Hey Everyone,

Welcome to discussion thread for the Covenant Eyes for Mac v 2.8.2 beta. 

 

Thread guidelines:

 

1.     To participate in this thread please register for the Beta by filling out this survey.

Registration only takes a couple minutes.

 

2.     Please keep the discussion on the topic of the beta test. This thread will be moderated

more closely than normal to keep the discussion on topic.

3.     Please refrain from posting your personal information here. Your

username will not likely cause much harm, but it is always wise to limit what
personal information you post online. Please send private concerns to GetSat@covenanteyes.com

4.     Feel free to speak up! Even if you think what you have to say may not be important, or has previously been said please share it with us. Your feedback allows us to continue to
improve our product. 

What is new in this beta?

 

·      Improved ability to connect at hotspots. What hotspot has frustrated you the most when trying to connect with Covenant Eyes installed? Install this beta, go there, and try to connect. Is your experience better or worse?

·      Improved handling of home and work network problems. Previous versions of Covenant Eyes sometimes have trouble allowing Internet access quickly when the computer wakes up.

 

We would like to know if you connected as effortlessly as you would expect to — as effortlessly as you would if Covenant Eyes was not installed on your Mac.

 

Anything out of the ordinary? Does anything seem out of place or not working as you expected? Let us know! We want your experience with Covenant Eyes to be delightful!

Photo of Aaron

Aaron, Official Rep

  • 41 Posts
  • 1 Reply Like
  • Excited!

Posted 5 years ago

  • 1
Photo of Jason Morris

Jason Morris

  • 9 Posts
  • 4 Reply Likes
I removed the Safari extension, then did an uninstall of the previous version (2.8.1).  Then rebooted and installed the new version 2.8.2b4.

So far I am noticing *dramatic* improvements in browsing and checking for updates in the App store.  I noticed no lag in getting auto-logged in to CE - I was already logged in by the time I looked, which is a huge improvement. 

Will continue to update with anything else I notice.
Photo of Aaron

Aaron, Official Rep

  • 41 Posts
  • 1 Reply Like
Thanks for your feedback, Jason! We look forward to hearing more about your experience with this beta.
Photo of Jason Morris

Jason Morris

  • 9 Posts
  • 4 Reply Likes
There is one issue that I have noticed so far.  It has only happened once, but since it also occurred in previous versions as well I think it's worth mentioning.

CE seems to randomly quit (or silently crash) from time to time.  It seems to be intermittent, and I'm not sure that it can be reproduced on demand.

This behavior has been the same in old version as the new;  Basically what happens is that I open up Safari, Mail or some other app requiring Internet access.  The app seems to be taking forever to load, so I look over at the CE icon in the menu bar to make sure it's connected, and lo and behold, CE isn't even running.

Somewhere along the way the app has closed or crashed, but gave no notification of crashing or closing.  I believe this happens when my MacBook goes to sleep.

I have confirmed that CE is set to load at startup.  As far as I know it always loads at startup.  The issue seems to be intermittent and related to sleeping/waking.  

When this issue occurs, I have to run CE from the Applications folder and then everything connects (to the Internet) and starts working normally again.

Some thoughts for directions to troubleshoot in:
a) Perhaps while sleeping it continues to run and eventually uses up too much memory or resources?
b) Perhaps it doesn't handle well situations where there isn't Internet access or access is slow? Could lack of Internet access cause a memory leak?
c) Perhaps it's related to Power Nap settings?  I do have Power Nap enabled while running off of the Power Adapter, however I don't have it enabled when running off of Battery.

Photo of Aaron

Aaron, Official Rep

  • 41 Posts
  • 1 Reply Like
Jason, this bug was discussed this morning and will be addressed in the near future. Thanks again for the great feedback!
Photo of psjoiner

psjoiner

  • 3 Posts
  • 1 Reply Like
Working better, but I still get an occasionally hiccup (M201 error).  It is often immediately waking from sleep.  But, if I have had it asleep for a while (overnight, for instance), it takes a while for CE to kick-in again.

Also, while you are working on things, can we get a retina version of the icon for the menubar?
Photo of Brent

Brent

  • 4 Posts
  • 1 Reply Like
I also have noticed some significant improvements, especially when "waking up" the computer - definitely a big improvement.

Regarding hotspots: Also a big improvement. I was in an airport today and CE was very responsive. There were a few times that CE crashed upon "wake up" while at the hotspot, and I had to restart it. It wasn't a big deal, and it was certainly better than having to reboot, which is what I used to have to do.

-- BB
Photo of Jason Morris

Jason Morris

  • 9 Posts
  • 4 Reply Likes
One suggestion:  CE doesn't seem not know when it's not running.  It doesn't seem to report crashes, nor does it seem to re-launch itself.  Perhaps a small companion program running in the background could constantly poll the app status, report crashes (both to the user and to CE programmers), and re-launch the primary app.  If the app immediately crashes 2 or 3 times in a row after re-launch, the companion program could report the issue to the user and provide steps for resolution (directions for uninstalling/reinstalling the app, calling tech support, etc.).
(Edited)
Photo of Aaron

Aaron, Official Rep

  • 41 Posts
  • 1 Reply Like

Great feedback, guys!

The good: It sounds like the hotspot improvements in this beta are helpful for you.

The bad: While developing this beta, we identified several layers of problems causing hotspot and connectivity issues. Although this beta solves a number of problems, more problems have been revealed.

I will be sending out an e-mail to everyone who has installed this beta for more feedback later today. I would appreciate it if you all could complete this survey to provide further feedback concerning your experience with this beta.

We will use the feedback from this survey to determine the next steps for these improvements.

Thanks again for the great feedback; it has been very helpful to learn about your experience with this beta.

Photo of Jason Morris

Jason Morris

  • 9 Posts
  • 4 Reply Likes
Sounds good.  Haven't received the survey so far.
Photo of Aaron

Aaron, Official Rep

  • 41 Posts
  • 1 Reply Like
Jason, the survey went out this early this morning. Have you received it yet?
Photo of Jason Morris

Jason Morris

  • 9 Posts
  • 4 Reply Likes
Not yet.  Wondering if maybe it blocked as spam or something?
Photo of Aaron

Aaron, Official Rep

  • 41 Posts
  • 1 Reply Like
I would check your spam folder just to be sure you did not receive the survey. If you can not find the survey e-mail, contact us at macbeta@covenanteyes.com and I will send you the survey directly.
Photo of Jason Morris

Jason Morris

  • 9 Posts
  • 4 Reply Likes
Getting an undeliverable from that address:

Delivery has failed to these recipients or groups:

macbeta@covenanteyes.com
Your message can't be delivered because delivery to this address is restricted.
For more information about this issue see DSN code 5.7.1 in Exchange Online.

Photo of Aaron

Aaron, Official Rep

  • 41 Posts
  • 1 Reply Like
Sorry about that, Jason. I have someone looking into that error code on our end.

Below is a link to the survey that I sent out.

https://www.surveymonkey.com/s/GMFJN7B
Photo of Jason Morris

Jason Morris

  • 9 Posts
  • 4 Reply Likes
Thanks!
Photo of Aaron

Aaron, Official Rep

  • 41 Posts
  • 1 Reply Like
Good news! This beta is now available on the Covenant Eyes downloads page! 

Thanks again for the great feedback on this beta! Feel free to let us know if you have any further thoughts or concerns regarding this version of the Covenant Eyes Mac client.
Photo of Brit Whittington

Brit Whittington

  • 4 Posts
  • 1 Reply Like
I was having problems getting version 2.8.1 to reconnect after my Mac woke up.  I was so frustrated I was about to toss Covenant Eyes.  They told me about the new version 2.8.2b4, and since I have installed it, it reconnects much better.  No real issues to speak of as yet.
Photo of Jake

Jake, Employee

  • 140 Posts
  • 11 Reply Likes
Glad to hear!
Photo of Brit Whittington

Brit Whittington

  • 4 Posts
  • 1 Reply Like
OK, I have had a couple of issues since the install.  One was just that Covenant Eyes was a bit slow to recover after coming out of sleep mode.  I was able to tell it to sign-in and it came up after a few seconds.

The most recent today, it would not recover at all.  I told it to sign-in, it appears to be signed in, but gave not indication that filtering was good.  Nothing on the Internet would respond.  I left it for almost 4 hours and it never recovered.  I tried to sign out and back in and do a refresh and nothing.  I had to reboot to get it to recover.
Photo of Brit Whittington

Brit Whittington

  • 4 Posts
  • 1 Reply Like
I'm still having issues with it recovering from sleep mode.  It's either very slow or gets the spinning beach ball of death.
Photo of Aaron

Aaron, Official Rep

  • 41 Posts
  • 1 Reply Like
Brit, thanks for sharing this information with us. Would you be willing to collect diagnostics for troubleshooting purposes? If so, please shoot me an e-mail at macbeta@covenanteyes.com. I will reply to you with the proper instructions to collect diagnostics.
Photo of Brent

Brent

  • 4 Posts
  • 1 Reply Like
Update: I have been having a few more issues with the beta recently. When waking up my computer and trying to sign in to CE, the icon seems to freeze. It can take 1-2 minutes for it to unfreeze. I have included a screenshot:

Photo of Brit Whittington

Brit Whittington

  • 4 Posts
  • 1 Reply Like
Have you tried clicking on the icon and selecting Sign in.  I find that helps sometimes.
Photo of Aaron

Aaron, Official Rep

  • 41 Posts
  • 1 Reply Like

Brent, clicking Sign In from the icon menu may help, as Brit has pointed out. We are currently working on a solution for this issue. I will post an update here as soon as I have something available.


Thanks again for the great feedback!