Covenant Eyes for Mac 2.6 Release Notes

  • 1
  • Announcement
  • Updated 4 years ago
  • (Edited)
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Old and no longer relevant. - chad

Hey Everyone,

Mac 2.6 Release Notes: 

  • Added support for Mac OS 10.10 (Yosemite).
Yo-Smite? Yaso-mitey? ... it was easier when Mac OS versions were named after large cats. Anyway, it works now.

  • Covenant Eyes no longer repeatedly asks to install the extension in Safari 7.1 and later.
It just REALLY wanted to make sure that you were protected. (Sorry about that.)

  • Fixed a spelling error.
Calling our Customer Support Team within the United States is now 100% less "tool free." 




That's it for this release folks. Mad props to the Mac guys.
Photo of John

John, UX Practitioner

  • 439 Posts
  • 78 Reply Likes

Posted 4 years ago

  • 1

There are no replies.

This conversation is no longer open for comments or replies.