iOS CE VPN disconnects for short periods of time

  • 1
  • Problem
  • Updated 3 weeks ago
On my iPhone, I go through short periods of time, maybe a minute or so, where I lose network connectivity. I think I'm on Wi-Fi every time. Basically, in my status bar, I lose the Wi-Fi icon and the VPN icon, and I just see the LTE up in the status bar. During this time I have no connectivity. If I go to settings, I see "VPN Connecting..." This has happened on my home Wi-Fi and work Wi-Fi. I haven't noticed it on a mobile data connection. This happens probably 4 or 5 times a day. It sometimes happens when I'm on the browser, and sometimes not.

I'm running iOS 13.2.3 on iPhone 7, with latest version of CE, but I think this has happened even before iOS 13.
Photo of Chance

Chance

  • 170 Posts
  • 22 Reply Likes

Posted 3 weeks ago

  • 1
Photo of Tom Park

Tom Park

  • 20 Posts
  • 4 Reply Likes
I also notice this. Particularly more with my ipad.  IOS CE becomes virtually unusable at times with my ipad. 
Photo of Andy Robinson

Andy Robinson, Official Rep

  • 11 Posts
  • 2 Reply Likes
Chance and Tom,

Thank you for bringing this up. It sounds like the VPN is possibly disconnecting when the phone switches from WiFi to data.

There is one setting that I'd like you both to check. It's called "Connect on demand." This can be accessed by:
  • Going to the Settings app
  • Tapping General
  • Tap VPN
  • Then tap on the "i" next to Covenant Eyes
  • "Connect on Demand" should be at the bottom, make sure that is turned on.
With that setting turned on, if you open any app while the VPN is disconnected, it should automatically reconnect.

If "Connect on Demand" is already enabled, there might be something else going on. I would suggest calling Customer Support (877.479.1119) and we can help troubleshoot this.

Thank you,

Andy