Galaxy S8 Chrome search Issue

  • 1
  • Problem
  • Updated 8 months ago
Every time I search on Google in Chrome (or if the Google app throws a result over to Chrome)the CE filter regularly blocks the search result. These are normal, non-mature searches. I select the "allow all google.com sites" option every time on the filter guardian override but it continues to happen. The only work around is to have my wife's password saved in the form for that filter override. Is there a workaround for this?
Photo of Jimmy Clark

Jimmy Clark

  • 3 Posts
  • 0 Reply Likes
  • Frustrated

Posted 9 months ago

  • 1
Photo of Syd

Syd, Official Rep

  • 58 Posts
  • 4 Reply Likes
Jimmy,
     Thanks for posting in this forum! Sorry to hear that the Covenant Eyes filter is being a nuisance on your Android Galaxy S8. Have your wife follow the steps below to add google.com as an allowed site to your allow list:

1. Navigate to covenanteyes.com
2. Select MyAccount from the top right-hand corner (your wife needs to sign-in with her UN/PW)
3. Select Manage Users
4. Select the filter option on the bottom of your profile box
5. Select the filtering tab from the top right of the screen
6. Add google.com to the allow list
7. Refresh the Covenant Eyes app on your phone
****To refresh Covenant Eyes, simply open the Covenant Eyes app on your phone, and select Refresh Covenant Eyes from the home screen menu of the Covenant Eyes app.

Then see if issue persists on your device. 

I hope this is helpful,

Syd
Photo of Jimmy Clark

Jimmy Clark

  • 3 Posts
  • 0 Reply Likes
Syd:  I failed to mention in my original post that I have already done this.  It was the first step.
Photo of Syd

Syd, Official Rep

  • 58 Posts
  • 4 Reply Likes
Jimmy, 
     My apologies for the late response. After you added google.com to the allow list, did you refresh the Covenant Eyes app on your phone? After making any changes to your filter online, you must refresh the Covenant Eyes app on your phone.

PLEASE NOTE: after adding google.com to your Allow List, ALL google searches will be allowed, even explicit ones.

     An alternative to adding google.com to your allow list would be moving your Filter Sensitivity Level (FSL) up. It may be that you have your FSL set to a lower level which is blocking google searches. The link below gives you a break-down of the FSLs that Covenant Eyes offers:
http://www.covenanteyes.com/support-articles/what-are-filter-sensitivity-levels-which-one-is-right-f...

For either option, please be sure to refresh Covenant Eyes by opening the Covenant Eyes app on your phone, and selecting Refresh Covenant Eyes from the home screen menu.

Best Regards,

Syd