Explicit Videos on Youtube aren't being blocked...

  • 1
  • Problem
  • Updated 2 years ago
So I have had big problems with youtube while using CE. Not with youtube not working, but CE not filtering explicit results and videos. Even when I search using graphic terms and view videos with graphic titles, they are not blocked by CE. My filter is on MT. Do I need to set my filter lower or is this a permanent problem with CE?

Other filters like Mobicip and Safe Eyes can do video by video filtering of youtube, so its not a technical impossibility.
Photo of Mitchell Stevens

Mitchell Stevens

  • 3 Posts
  • 0 Reply Likes
  • Frustrated

Posted 3 years ago

  • 1
Photo of Mitchell Stevens

Mitchell Stevens

  • 3 Posts
  • 0 Reply Likes
I posted this a month ago and no response at all... What's up? Is it cause I mentioned competitors?
Photo of Heather

Heather, Official Rep

  • 81 Posts
  • 12 Reply Likes
Hi Mitchell,

Thanks for your post. I promise we will never not respond because our competitors names are invoked.

The problem with filtering sites like YouTube is that they are HTTPS, or encrypted, for privacy. Sites that you have to sign in to, tend to have filtering issues, because of this encryption. An encrypted site makes it hard for software like ours to accurately scan content, allowing some material to come through.

That being said, you shouldn't be able to find much adult content with the filter engaged. Sometimes the static photos for suggested videos (on the right side of the YouTube window) may show up, but if you click on those video to watch them, it will not allow the content through. I went ahead and tested my username set to MT and searched YouTube, but found no pornography videos, whether I was signed into Google or not.

Perhaps you can give us a call so we can see what might be going on for you specifically.

Thanks!

heather