Covenant Eyes not able to load up after update to High Sierra

  • 1
  • Problem
  • Updated 5 months ago
I have a MacBook Pro and an iMac. On both, I've noticed just today that my Covenant Eyes is not able to be opened. Instead it is giving me this error message when I try to open the app, "The application 'Covenant Eyes' is not open anymore." Which is obvious and unhelpful :)

I suspect this is due to recent updates to High Sierra. There have been a lot of updates to High Sierra, and I'm not sure if one of them in particular has blocked Covenant Eyes. My iMac still allows me to use the internet, but my MacBook is even preventing me from connecting to the internet. 

All i've done is try to restart the computer and search this forum for help...to no avail.

Any help would be appreciated. Thanks!
Photo of Stan Mistak

Stan Mistak

  • 1 Post
  • 0 Reply Likes

Posted 5 months ago

  • 1
Photo of Robert B

Robert B, Official Rep

  • 232 Posts
  • 16 Reply Likes
Stan,

Thanks for posting and you're right. To work on High Sierra, you need Covenant Eyes version 2.8.10 or newer. Previous versions of Covenant Eyes will not work on High Sierra. The newest version is available when you sign in at covenanteyes.com and go to the Downloads section of the Menu.

If you need further assistance, please contact our Customer Service team at 877-479-1119.

Robert