Conflicting instructions: On upgrading to Ver >= 5.0

  • 2
  • Problem
  • Updated 5 years ago
  • Solved
email i received from CE states, "we are strongly recommending that our users uninstall before their first upgrade to any version of Covenant Eyes for Windows Version 5.0 or higher."  I'm running CE 4.5.3 2301 yet when I click "check for upgrades" it tells me I have the latest version of CE.  What's up?
Photo of Ron Krikorian

Ron Krikorian

  • 1 Post
  • 0 Reply Likes

Posted 6 years ago

  • 2
Photo of John

John, Official Rep

  • 439 Posts
  • 79 Reply Likes
Hey Ron,

Sorry about the confusion for this. In a nutshell because the old version (4.5.3.2301 and prior) is not compatible with the newer versions, automatic update is not yet tuned to the newest versions of Covenant Eyes. 

To get the newest version from CovenantEyes you will need to uninstall your current version, and then go to https://covenanteyes.com/myaccount/downloads/ to install the most recent version.

We hope to be out of this transition period before long, at which point auto update will be able to function as it is intended and there will be less confusion.

Thanks for hanging in there with us as we strive to provide the best service possible

- John
Photo of Tim Engler

Tim Engler

  • 8 Posts
  • 0 Reply Likes
I'm wondering why I didn't receive this email, as I'm still on the old version and it's causing me a whole lot of grief with it's conflicts.
Photo of John

John, Official Rep

  • 439 Posts
  • 79 Reply Likes
Tim, I believe the email was sent out to all of our users. (at least that is what I was told)

It is quite probable that your email client flagged us as spam or an advertisement however, and if that is the case then I am sorry you were unable to get the message. You can certainly still upgrade, and our program has only continued to improve since we sent out that email.