Problems with Chrome version 37

  • 2
  • Problem
  • Updated 5 years ago
  • In Progress
  • (Edited)
We have received word that a number of our customers have been experiencing issues with Chrome since they released their update to Chrome 37 yesterday. Our team is currently investigating the source of the issue and we'll update this thread with information as it becomes available.  
Photo of Alaina

Alaina

  • 259 Posts
  • 8 Reply Likes
  • Waiting for clearer news

Posted 5 years ago

  • 2
Photo of Alaina

Alaina

  • 259 Posts
  • 8 Reply Likes
We have confirmed that Chrome 37 works on the current Beta of Covenant Eyes for Windows  (version Version 5.1.1.2) on Windows 7 and 8. This is available on the Downloads page in MyAccount.

If you are currently running a version of Covenant Eyes previous to Version 5 you do have to uninstall Covenant Eyes to upgrade. If you are on version 5.0 or later you can upgrade over your current version.
Photo of Doug Wolfe

Doug Wolfe

  • 1 Post
  • 0 Reply Likes
I had the problem and I had the latest release version of Covenant Eyes. I found this thread on a Google forum that indicated a number of people solved the problem by uninstalling Covenant Eyes and reinstalling it. That solution worked for me as well.
https://productforums.google.com/forum/#!category-topic/chrome/windows7/sj5s7Dugx8w
Photo of Michael Fisher

Michael Fisher

  • 1 Post
  • 0 Reply Likes
I have been tearing my hair out with this over the past week.  Google Chrome stopped working on all my work and home computers, and I had been assuming it was a Windows Update that broke Chrome.  Just uninstalled CE and Chrome's working fine.  Hopefully installing the latest version of CE will resolve the issue.
Photo of John

John, Official Rep

  • 439 Posts
  • 79 Reply Likes
Thanks for Posting the link to the Chrome forum Doug. It is neat to see Covenant Eyes members helping each other online. Awesome.

As a relevant side note, our newest builds of Covenant Eyes should remove or reduce the "Covenant Eyes is Malicious" message that Chrome has been throwing out forever... *fingers crossed
Photo of John Gleich

John Gleich

  • 1 Post
  • 0 Reply Likes
Thanks for the info on this.

I was able to uninstall last night, but when I tried to reinstall (using Chrome and Firefox each), I got the "malicious download" information. I may not have selected the right one (version 5.0.xxx) and maybe that was the problem... I'll have to try it again when I get home tonight.
Photo of Alaina

Alaina

  • 259 Posts
  • 8 Reply Likes
Since you've been getting the malicious download message, I would suggest version 5.1.1.2. It's our current open Beta and includes revamping of the processes that were causing the malicious message, so you shouldn't have that problem with it. 
Photo of Brad

Brad

  • 10 Posts
  • 0 Reply Likes

Hello. I uninstalled the older version and downloaded the newer version so my chrome could work. I had to disable my anti-virus and restarted my computer reinstating my anti virus. However now my anti virus is detecting a Trojan that seems to be attached to the latest covenant eyes download! And now several of my system processes are not working due to malware. my antivirus says it detected "Trojan.Win32.Hosts2.gen"  located in C:\Windows\System32\drivers\ect\hosts.   I am 100% sure it was from the covenant eyes download because the same thing happened to another computer right after I downloaded the new version.  PLEASE HELP!


Photo of Alaina

Alaina

  • 259 Posts
  • 8 Reply Likes
Could you tell me what antivirus you're using? 

There is a host file change that we do make, but I've never seen it called that. I did forward this to our Windows devs to see if they are somehow related.
Photo of Alaina

Alaina

  • 259 Posts
  • 8 Reply Likes
Instead of updating two threads, I am going to update the topic specifically about this, which is found here - https://helpforum.covenanteyes.com/covenanteyes/topics/virus-when-i-install-newest-beta-version
Photo of Tim Engler

Tim Engler

  • 8 Posts
  • 0 Reply Likes
If this is a conflict with an older version of CE why do I still have the old version, and why have I not been prompted to update? And why does it say that it is up to date when I check for upgrades?
Photo of John

John, Official Rep

  • 439 Posts
  • 79 Reply Likes
Hey Tim,

I replied to your comment in another thread. I have pasted it here as well for clarity

"Yeah, I know that is confusing, sorry.

4.5.3 is the 2 year old version of Covenant Eyes. Since then we have gutted the entire program and replaced the internals to make it faster/more stable/more capable. Which is AWESOME by the way. 

However because of the dramatic changes, 4.5.3 is not compatible with the 5.x.x series of Covenant Eyes versions, so you cannot do an automatic upgrade. So the check for updates option is not actually working properly in that version, hence the invalid message.

I really want to fix this, but I have been told that it is extremely difficult. We will see tho.

Thanks for your understanding"
Photo of Tim Engler

Tim Engler

  • 8 Posts
  • 0 Reply Likes
OK, thanks, that makes sense.