Celapid process consuming 100% CPU

  • 1
  • Problem
  • Updated 6 years ago
  • Solved
I'm not sure what caused this, but I noticed recently that there's a process called "celapid" on my computer which is always running, can't be killed permanently, and which consumes 100% of my CPU. It's pretty annoying because I think it's killing my battery life, and I can't do anything about it.

Is this process part of the CE software?

I installed the new Mac beta about a week ago, and then noticed this and tried to revert to the last stable version, but it doesn't seem to have fixed this problem.

Any help would be greatly appreciated!
Photo of Stephen Martinis

Stephen Martinis

  • 2 Posts
  • 0 Reply Likes
  • annoyed

Posted 6 years ago

  • 1
Photo of John

John, Official Rep

  • 439 Posts
  • 79 Reply Likes
Official Response
Hey Jibang,

Celapid IS a Covenant Eyes process. 

A little background, when this post first came to light we had recently done some improvements on Mac which had included this process, that information however had not yet made it out of dev land and into general knowledge.

The initial problem of celapid eating up a lot of memory/processing power was quickly fixed and I thought we had come back here to update the post, which we clearly did not...  (oops)

Sorry about any confusion,