CE interferes with page loading sometimes

  • 1
  • Problem
  • Updated 8 years ago
  • Solved
Archived and Closed

This conversation is no longer open for comments or replies and is no longer visible to community members. The community moderator provided the following reason for archiving: Super Old.

I'm having a problem with CE on my mac (Snow Leopard). I used CE for 1 year, then took a couple months and tried out other products because I was having problems after upgrading to Snow Leopard and I suspected CE to be the cause. I decided to switch back to CE, and immediately the problem came back. Here is what happens:

About 1 in 10 pages that I try to load only load partially. The status bar in Safari will say something like "Loading www.site.com/page Completed 12 of 14 items." Reloading that page enough times will eventually allow it to get past 12 of 14, and proceed to 14 of 25 etc, until Safari knows about all of the items it is supposed to load and actually loads them. (Every time this happens, it is clear that Safari hasn't yet figured out what the actual number of items to load is.)

This happens on any internet connection I use (tethered through mobile phone, dsl, cable, fiber), and it happens with the built-in firewall on or off. I'm not sure if anybody else is experiencing this, but it is just frequent enough to drive me crazy. I use the internet all day for work, and it is something that I would expect most people see infrequently enough that they just ignore it and assume it's a problem with the internet.

The reason it annoys me so much is that I'm incredibly impatient, and I hate having to reload a page 3 or 4 times until it decides to finish loading. Plus I know I can make the problem go away instantly by uninstalling CE.

It used to be that CE was truly seamless and stayed in the background and didn't interrupt my browsing at all. Now I'm always selecting "Check for upgrade". I long for the day to come when it really works well again.
Photo of Joseph Bayly

Joseph Bayly

  • 2 Posts
  • 1 Reply Like
  • impatient

Posted 8 years ago

  • 1
Photo of Luke Gilkerson

Luke Gilkerson

  • 40 Posts
  • 3 Reply Likes
Joseph,

We are targeting December 22 for the release of our newest version of CE which works better with Snow Leopard. We hope this will clear up your problem.
Photo of Luke Gilkerson

Luke Gilkerson

  • 40 Posts
  • 3 Reply Likes
We've just released the newest version of our software for Mac - http://www.covenanteyes.com/files/Mac...

This should help with Snow Leopard issue. Go to our download page: http://www.covenanteyes.com/download/

BTW - This is only available on the "downloads" page on our website, not as an automatic upgrade.
Photo of Joseph Bayly

Joseph Bayly

  • 2 Posts
  • 1 Reply Like
After using the new version, I think the problem is pretty much gone. Thanks for your work and letting me know about the manual update.

This conversation is no longer open for comments or replies.