CE Doesn't Work in Virtual Machine on VMware

  • 1
  • Problem
  • Updated 4 years ago
Hello,

I have CE installed on my Windows machine, but use virtual machines in VMware to run other operating systems. My problem is that CE allows me to be connected to the internet on my virtual machine without even being signed into CE. Even when signed in, it doesn't seem to block or report content. I use VMware to run other operating systems because I am in IT and would love to continue using it.

Is there something I can do to fix this?
Photo of drew

drew

  • 6 Posts
  • 0 Reply Likes

Posted 4 years ago

  • 1
Photo of Gerry Simmons

Gerry Simmons

  • 36 Posts
  • 5 Reply Likes
You would need to install CE on each VM. Hopefully, they are all Windows! ;^)
Photo of drew

drew

  • 6 Posts
  • 0 Reply Likes
Thanks Gerry. Actually the majority are various Linux distros. While i'm sure CE works fine once installed on each VM, the problem is that I can easily access/create another VM without CE installed during weaker times. Doing so would make it somewhat less available though, so that will probably be my next step if there is no way for CE to monitor or block internet access in a VM.
Photo of Chance

Chance

  • 181 Posts
  • 24 Reply Likes
I haven't used VMWare, but I have used Virtualbox. What I noticed is that if I used Bridged Adapter for my network settings, it would treat that Virtual machine as its own unique network instance. If I used the default mode (I think NAT), the guest machine would have its traffic monitored on Covenant Eyes.  If there is an equivalent mode for VMWare, and you can do something to disable the Bridged Adapter mode and keep it disabled, maybe that would work.
Photo of BarneyFifeFan

BarneyFifeFan

  • 18 Posts
  • 1 Reply Like
Based on past experience, Drew, Virtualbox is your best bet. It seems to be monitored by default, unlike VMWare. I'm not sure if that's even an option for you, but if it is, it's worth checking out.
Photo of drew

drew

  • 6 Posts
  • 0 Reply Likes
Thanks to both of you! I have VirtualBox installed as well on my computer, so I will see if that works better.