CE blocking league of legends connection to servers ect.

  • 1
  • Problem
  • Updated 2 months ago
Ever since downloading CE several games have had problems connecting to game servers (such as LoL ect.). It was not until I ran a diagnostic test that I realized CE was responsible. I've seen other people on the forum having the same problem in the past years. I dont think I have CE filtering service, just the accountability one. Is there an older/newer version that would fix my problem?
Photo of Cliff Jones

Cliff Jones

  • 3 Posts
  • 0 Reply Likes

Posted 7 months ago

  • 1
Photo of Syd

Syd, Official Rep

  • 55 Posts
  • 4 Reply Likes
Hi Cliff,
   Thank you for posting in this forum! Sorry to hear that Covenant Eyes is prohibiting games from connecting properly. For me to assist you, please answer the following:

1. Do you use Steam to launch these games?
2. What version of Covenant Eyes are you running? 
    >>>To find out what version of Covenant Eyes you are running, simply click on the arrow in the bottom right-hand corner of your screen, by the time and date on your PC. Once you click on the arrow, right click on the Covenant Eyes icon and select About Covenant Eyes.

If you are using Steam, we do have a beta version available (version 7.2.42) that has been working well for some Steam users. Please let me know if you are using Steam and what version of Covenant Eyes you are running, then we can go from there.

Best Regards,

Syd
(Edited)
Photo of Cliff Jones

Cliff Jones

  • 3 Posts
  • 0 Reply Likes
No, my problems only happen with non-steam games, specifically league of legends. My current version is 7.2.41. Thanks
Photo of Syd

Syd, Official Rep

  • 55 Posts
  • 4 Reply Likes
Cliff,
    Thanks for replying! I have another version for you to try: version 7.2.43. This version has compatibility fixes for League of Legends. Please email me at sydney.w@covenanteyes.com so I can provide you with the download for 7.2.43.

Syd
(Edited)
Photo of Brad Isaak

Brad Isaak

  • 1 Post
  • 0 Reply Likes
Hi I've had this exact issue and Riot is telling me League isn't working because of CE. Please send me this link at bpi@fpu.edu
Photo of Robert B

Robert B, Official Rep

  • 186 Posts
  • 14 Reply Likes
Brad,

Thanks for reaching out. Since the time of the original post, 7.2.43 has been replaced by a newer version. You can get the replacement (7.2.47) by going to covenanteyes.com and signing in to your account.

In the Menu, select 'Downloads'. Version 7.2.41 will be listed at the top, but scroll down. You'll see 'Covenant Eyes for Windows (BETA)'  and just below that 'Version 7.2.47 (Release Notes)'. Click on the nearby 'Download Now' button.

If you run into a snag, please call the Customer Service team at 877-479-1119.

Robert
Photo of Wes

Wes

  • 2 Posts
  • 0 Reply Likes
Hi Robert,

I've been having the same issue on my end, and I've tried updating to version 7.2.47, but simply running the installer I get from the download page isn't working. I tried to completely uninstall and reinstall, but the uninstaller wizard crashed. 
Can you help? Thanks.
Photo of Robert B

Robert B, Official Rep

  • 186 Posts
  • 14 Reply Likes
Wes,

Thanks for reaching out.

I have seen some cases of the uninstall wizard crashing. The best thing to do is call our Customer Service team at 877-479-1119 and tell them that. They will help you with an alternative method of removing CE and upgrading to 7247.

Calling directly will get you the fastest help. That team takes calls from 8 am (EST) to 11:45 pm (EST), Monday - Friday. On Saturdays, they are available from 10 am (EST) to 5:45 pm (EST). Covenant Eyes is closed on Sundays.

Although it's a slower process, I know that email works a little better for some people. If that's the case for you, then email support@covenanteyes.com and a member of the Email team will help you.

Thanks for posting,

Robert
Photo of Wes

Wes

  • 2 Posts
  • 0 Reply Likes
Thank you for your response! 

I actually ended up figuring it out. I uninstalled CE while my computer was in safe-mode, and this thankfully worked as I am now on the latest version and my problems have been resolved. 
Photo of Cliff Jones

Cliff Jones

  • 3 Posts
  • 0 Reply Likes
Hey, I've just recently run into the same ol problem even with the 7.2.43 version, though it worked for many months. I figured it must be out of date or something has changed with the lol client. I have uninstalled it for the time being and was wondering if you had a newer version that is compatible. Thanks
Photo of Syd

Syd, Official Rep

  • 55 Posts
  • 4 Reply Likes
Cliff,
    My suggestion to you would be to download version 7.2.48 from covenanteyes.com. This version has more updates and patch fixes than 7.2.43.


Syd
(Edited)